pgmfi.org

Hacking up Honda's ECU
It is currently Sun Dec 16, 2018 6:47 am

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: EcuControl Plugin
PostPosted: Sat Sep 15, 2007 8:24 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
This will be the place for the EcuControl plugin that ive been working on. Please try it, and if you have any questions/comments/requests...please PM me and i will post your PM in this thread (since this group is semi-locked).

see posts below for descriptions of updates.

if you run an innovate wideband (lc-1 or lm-1) or any other innovate device...please try the seperate innovate channels and let me know if it works, or doesnt work for you...


v.6.1.8 - posted 09-15-07
Code:
-added gear calculator
-fixed mph calculation
-added digital gauges
-added support for innovate wbo2 (good for any linear output)
-added gearing and tire input (for gear calc)


feeling generous?
find the changes useful?
have a special request?
throw me a couple bucks to help pay for vb6...

Image

or just donate to the cause @ pgmfi@pgmfi.org


Donation List :shock:
9/24/08 - PGMFI - $19
2/21/09 - guest0001 - $5
2/23/09 - esi42 - $10
3/25-09 - turboD15 - $5 & chipped PM6
4/6/09 - The Acid Beaver - $20
5/30/09 - sanimalp - $15
6/6/09 - hondaworkshop.com - $10
10/6/09 - guest0001 - $2
11/27/09 - clwtwizted - $15
1/1/10 - guest0001 - $5
1/6/10 - Walterronny - $15
1/7/10 - kablammyman - $5
4/18/10 - Aragorn - $20
4/21/10 - singleslamhp - $20
5/14/10 - mazdarcing - $10
6/17/10 - fuse - PR3 ecu
8/2/10 - sophocha - $10
8/31/10 - oldmonte - $40
8/31/10 - a9turbo - $10
10/11/10 - jense - $10
10/21/10 - patprimmer - $20
2/3/11 - beboo - $30
2/12/11 - rich777 - $10
2/27/11 - gtpilot - $100
4/21/11 - steinar - $20
7/9/11 - generallee01 - $40
7/27/11 - BladeSoul - $20
10/5/11 - 90zcrex - $25
12/20/11 - RiB'$ - $30
3/9/12 - xsnsx - $75
3/27/12 - Zoltan - $50
8/6/12 - *anonymous - $5
6/8/13 - jbretthowell - $5
9/14/13 - shadow032 - $10
3/30/14 - riverrunner06 - $20
4/5/14 - DAQS - $10
10/13/16 - McAwesome - $20


You do not have the required permissions to view the files attached to this post.


Last edited by fastcrxsi90 on Mon Dec 03, 2007 1:31 pm, edited 4 times in total.

Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Sep 24, 2007 7:41 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
v.6.1.9
Code:
-fixed map calculation for boost
-map fix is good for stock map sensor, if anyone tests this we can verify it works for other sensors
-digital gauges are customizable
-max and min recall are added to digital gauges
-fixed setting textboxes for numeric input


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Oct 01, 2007 6:51 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
mynameistin wrote:
i was gonan test your ecucontrol but i get the activex cant create object when itry to load it.


if the file downloads as ecucontrol_339.dll, etc...please rename to ecucontrol.dll and then load into TE. sorry for the screw up, i never actually downloaded it from the site to see if it worked. :?

i will try posting future updates as zip files.....

another update coming soon...if you have any requests please PM me...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Oct 28, 2007 10:15 am 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
v.6.1.10
Code:
-added analog gauges similar to standalone

-added premade digital gauges from standalone

-added statistics tab for main ecu data

-added 4-cell or 1-cell map trace averaging

-map trace can be averaged for entire logging session or for user inputted number of samples

-added a grid for all ecu data

-grid incorporates sensor voltages, calculated data, inj. durations, duty cycles, etc. (values are not correct yet...need to add multipliers to calcs)

-added a dynamometer tab, this calcs hp and torque...also has a dyno run button which collects hp, tq and rpm which is savable as a csv for graphing. includes sae correction factor.

-dynamometer only works for english units so far and results have only been tested by me (make sure to fill out all info under settings.

-added a vss correction mulipler under options

-added check box for calculating gear under options

-included with .dll is the table of target afrs, this can be automatically loaded. targets can be changes within ecucontrol and saved

-new fuel values based on wideband data can be calculated and your TE fuel map will be updated

-added various other stuff that isnt coming to mind right now...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Nov 05, 2007 2:34 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
just an update of whats coming next...with v.6.1.11

ive succesfully added the ability to input up to 8 channels of "daisy chained" devices from innovate motorsports. :D

this means that if you have an lc-1 or lm-1 you no longer have to disable the o2 sensor and hook up the analog out to pin C16. just hook up your serial/usb cable from the ecu and the serial cable from the innovate device to your laptop and connect to both ports within the plugin.

this also means that in addition to afr/lambda values, you can also log/trace egts, chts or any other input you want. ive added another map trace table, so you now have the ability to do a trace on:
1. C16 wb/nb value, C16 voltage or any of the 8 additional channels
2. any ECU value or voltage or any of the 8 additional channels

i have quite a few little things to finish before i release this... since i am the only one testing this, i have to try this on another computer without logworks to make sure that all the correct dll files are included. and my car is now down for the winter, so it may be awhile before i do anymore testing.

:arrow: on another note: does anyone want to keep the statistics tab that keeps track of max, min, average values for various sensors? i thought it was nice to see max boost and max temps...but dont really need it. ive hit the maximum number of controls allowed on a single form (according to vb6)...and need to either delete something, move it to another form or create some naming arrays.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Dec 03, 2007 1:22 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
welfarepc informed me about the plugin not loading (v.6.1.10). it ended up being that ecucontrol installer was not used...so i am providing the old plugin installer for people who have this trouble. it has all of the correct files needed to run my version of the plugin.

*edit:
the file is too big to upload....so for now if you need it let me know and i can email it to you...

*edit(2):
it worked today! this is the standalone installer...i figured that it was more interesting than the old plugin installer...


You do not have the required permissions to view the files attached to this post.


Last edited by fastcrxsi90 on Thu Jan 17, 2008 6:17 pm, edited 4 times in total.

Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Dec 03, 2007 1:24 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
i finally tested this version on a computer without logworks and everything loaded up fine. make sure to read below about the attached files.

v.6.1.11
Code:
-added seperate statistics viewer
-added innovate tab which can connect to up to 8 daisy chained innovate devices through the serial/usb port
-channels can be named and assigned units
-enhanced gauge package
-afr gauge can be set to wb, nb, voltage or any of the 8 added channels
-added tps calibration in settings, to use just check box/apply and either drive around or calibrate with key on engine off...uncheck box when done.
-added second maptrace grid....sensors for both maptraces are user selectable but the fuel side is geared towards afr.
-added a file type so that vehicle information can be loaded and saved easily...example is attached (filename.info)


attached with .dll are the following files:
mts.dll
mtssdk.oca
eChartControl.ocx
please place these files in the same folder location as the plugin that you are loading into TE. i.e. if your ecucontrol.dll is loaded from My Documents, then place these files in My Documents.

again...any questions/comments please let me know. also if you have sucess or cant get it to work please PM me. :wink:


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sat Dec 22, 2007 2:54 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
has anyone tried v.6.1.11 yet? :?

i havent heard anything yet so i assume it either works fine, nobody can get it to work or nobody cares.... let me know if things dont work so i can fix the problems...or change things so they work better...

im also curious if the innovate channels are working for anyone...


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Thu Jan 24, 2008 6:13 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
kablammyman wrote:
1) When starting the plugin, I aways get a "No MTS Ports available" message. I have no idea what this means...or if its even a bug, but I'd thought I would let you know. This doesnt seem to have any negative effects however.

2) In the map trace functions, I noticed that the cells for -3 inHg are always blank, but .5 psi and -4inHg are filled in

3) I cant autotune. I have the wideband enabled (plx m-series) and I loaded the target afr csv files, but the buttons to calculate AND adjust TE map the new fuel values tab are always grayed out.

4) Does the Average tab give me the fag afr the cell in the fuel table produce? Is it safe to use these vales to as the current afr comming from said cell?

5) What is the "point count" tab for?

6) This is a minor issue...may not be even worth looking at, but, when filling out the information for your cars gearing, everytime you clear the cell, you get a "please input a number" message. It gets annoying, but it doesnt interfere with the input


1) The "No MTS Ports available" message is from the combobox under the innovate tab looking for available ports to add to the list. On my laptop if i dont have the usb plugged in and i start the plugin i get that message...if you have the usb plugged in that "COM #" is added to the list. If you arent using the innovate tab...you dont have to worry about it, otherwise plug in all cables before opening the plugin.

2) That is an issue with the rom...see the work that 1net did to fix that with ng61 http://forum.pgmfi.org/viewtopic.php?t=15214

3) I will look into and fix that, they are supposed to enable when you start logging with any of the wideband selections. I will also be adding a "true" autotune timer and settings for min and max change...so the buttons may dissappear soon.
*edit i just looked....you have to have the target afr table loaded through the autoload (File>Set Target AFR Autoload...). just loading the target afr table wont enable the button...thats an error on my part. so for now set the autoload and restart the plugin.

4) Yes/No. I set up single cell and 4-cell logging each with the ability to average the entire sessions values or just the previous X amount of sampled values (user entered number).

For example if you average the entire session, and you get values of 12.0, 12.5, 12.1, 13.0 and 12.7...the value recorded is 12.46. If you average the session based on 3 values, and you get the same afrs...the value recorded is 12.60. (the avg of the last 3 values)

If you have the number set too high, you may not even get any values recorded...

5) Just to see how many "hits" you have at each cell...its calculated for averageing so i added it to a grid. Its not really needed and i may take it out. If you average based on a certain number, then you can see which cells you hit but didn't get a value for.

6) I will fix that...it might be better to check for all numeric values when apply/close is pressed instead of when entering info.

hopefully that makes sense, if anyone need clarification let me know. I also started working on an instruction/how to use document to include. If i start getting bored i will hopefully finish it.


Top
 Profile  
Reply with quote  
 Post subject: Re: EcuControl Plugin
PostPosted: Sat Feb 16, 2008 7:27 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
v6.1.12
Code:
-added support for 2.5, 3.0 and 4.0 bar Motorola map sensor logging.
-added better support for a fuel map autotune (suggestion from kablammyman)
     -can view what new fuel value should be or percent difference from original
     -can highlight and change specific cells on the fuel map (right click for menu)
-upgraded TPS calibration tool
-added autotune menu to settings/options


i have not tested this on a vehicle, so please try it out.

please let me know if this works for you...still curious if the innovate channels work for anyone. if i get a response that the plugin works fine...i will remove v6.1.11.

i also added an "instruction manual" to download...its not done, but i wanted to post what i had. when i update it, i will post new versions. any suggestions or if you want to help add stuff....please let me know.


Top
 Profile  
Reply with quote  
 Post subject: Re: EcuControl Plugin
PostPosted: Wed Feb 27, 2008 8:54 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
kablammyman wrote:
Hey, I've been using your plug-in a lot, and here are some bugs I have notcied.

1) The afr adjusment must be set everytime the plug in is used. The value will always be in the input box, but it wont be used unless you manually re-enter the value, and hit the apply button. This did not happen in the previus versions

2) When adjusting the fuel map from your plug in, the suggested value is not what is put/used in the auctual map. Ex cell 1300 -17 suggest 2.51. The value you get when applying the chnage is 2.65. (this is an example with REAL values.)
or 1300 -7 suggest 4.17, the orignal value is 4.38. i got 4.25

3) I told yopu this before, but the boost vac gauge doesnt work. However, it does move to -10 when you blip the engine while in netural

that is all i found so far


settings>autotune has settings for max percent change and max value change...just up the values if you want the exact change. i added them in case of any "bunk" afr values that may be recorded...

v6.1.13
Code:
-fixed afr correction value to load on startup (variable had no value)
-fixed boost/vac reading so gauges and live data grid should work now
-added checkbox under settings>autotune for checking for RTP connection for new fuel value calculation.  this changes the way the new fuel values are calculated based on if the car is running on the continuously updated maps (RTP) or if running on the originally loaded bin (burned onto chip).


Top
 Profile  
Reply with quote  
 Post subject: Re: EcuControl Plugin
PostPosted: Wed Mar 19, 2008 7:21 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
BiGZ wrote:
using your ecu control plugin v6.1.11,but it quit logging complete logs (only a small log results at end of session) Tried v6.1.13,but it always says "type mismatch" when hit connect.


i think i fixed the "type mismatch" error...i didn't notice that since i am unable to test on a vehicle. the slow log to file was due to computer speed...

v6.1.14
Code:
-fixed "type mismatch" error
-added coding for basic obd1 logging, only has low cam map trace...use mynameistin's version of TE for opening the bin for now.
-recoded some stuff so that any size map can be used...not just 30x17.


Top
 Profile  
Reply with quote  
 Post subject: Re: EcuControl Plugin
PostPosted: Sun Mar 30, 2008 8:36 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
v6.1.15

Code:
-added additional wideband support (default formulas for non adjustable...anyone know what the autometer voltage to afr relationship is?)
-make sure to check your o2 sensor selection, because i changed the values around
-added a checkbox to turn on/off the new fuel value calculation
-fixed an error in the additional sensor map trace
-fixed the 4-cell map trace averaging...its still not a "weighted" average, but the cells should average correctly now
-i did something else, but just lost my train of thought... :roll:


Top
 Profile  
Reply with quote  
 Post subject: Re: EcuControl Plugin
PostPosted: Thu Apr 15, 2010 7:18 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
v6.1.16
Code:
-added support for ng63
-added eld logging
-real fuel pulsewidth values
-real timing values (BTDC)
-real drive gear value
-fixed map logging to use either hard coded barometric pressure, or baro sensor value itself
-changed baro logging units to psia
-additional error handling


Top
 Profile  
Reply with quote  
 Post subject: Re: EcuControl Plugin
PostPosted: Thu Apr 22, 2010 8:03 pm 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
v6.1.17
Code:
-edited for changes required by ng63 revisions


http://forum.pgmfi.org/viewtopic.php?f=7&t=20342&start=15&sid=0a21b2f51574e6b6cc4af299e70fc9dc#p122543


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB® Forum Software © phpBB Group