pgmfi.org

Hacking up Honda's ECU
It is currently Fri Mar 01, 2024 1:10 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sun Nov 12, 2006 2:46 pm 
Offline

Joined: Sun Nov 12, 2006 1:56 pm
Posts: 3
Hi all,

I own a Willem programmer (see the pictures for pcb version), and I'm trying to burn an EEPROM (SST27SF512).

I can successfully read and erase the EEPROM, but my problem is I can't burn anything. There is always errors when veryfing the written data (and I can see nothing has been written).

I'm using "Willem Eprom Programmer" version 0.97g, and I tried version 0.97ja without more success...

I really don't know what is wrong with it, I followed several tutorials but it still doesn't work.

Could you please help me figure out what's wrong with my programmer ?

thanks


Image
Image


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Sun Nov 12, 2006 6:53 pm 
Offline

Joined: Tue Mar 21, 2006 5:28 pm
Posts: 22
I had a simular problem. It would say it is empty but really isn't, I think you may be missing a step. I use my enhanced burner on pcb3 not willem(at the top), make sure all of your switch settings are correct, put the chip in with it at the bottom of the socket and lock it in. Click erase and it will tell you to choose jumper W27E which is W27C on mine, to do this click the black button on the right untill it gets to that point, then click O.K. It will flash the lights on the board, at this point hit the left black button (reset) and it should show it is erasing, then put the jumper back to W27E click O.K., then hit the reset button again. At this time do a blank test and it should show that the chip is empty, if not try again, sometimes it takes more than once for mine to erase properly. Now that you are empty click file and load the file you wish to burn, make sure to put 8000 in the offset hex at the bottom right of the eprom program, click burn. It will burn and verify if you did everything correctly.

I hope this helps, the step I was missing was the reset after the erase process.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Nov 13, 2006 10:36 am 
Offline

Joined: Sat Apr 09, 2005 9:53 am
Posts: 625
ludeconduct wrote:
make sure to put 8000 in the offset hex at the bottom right of the eprom program


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Nov 13, 2006 3:38 pm 
Offline

Joined: Sun Nov 12, 2006 1:56 pm
Posts: 3
hi ludeconduct,

Thanks a lot for your help, I'll try doing it this way.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Nov 22, 2006 11:28 am 
Offline

Joined: Tue Oct 24, 2006 1:07 pm
Posts: 211
i'm using the pcb45 board (the newest) and i write/erase/verify/read all day long to SST 27sf512 chips.

on my board i have to set a jumper to erase, and remove the jumper to program.

also, set hex location to 8000.

search the wiki, there is a HOW-TO burn SST chips with your exact board posted.

goodluck bro, you'll figure it out,
-Luke


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Wed Nov 22, 2006 6:16 pm 
Offline

Joined: Tue Mar 21, 2006 5:28 pm
Posts: 22
The write up on the Wiki is for a dual powered not the enhanced. His board has electronic jumpers not manual jumpers that you add/remove for erasing and burning.


Top
 Profile  
Reply with quote  
PostPosted: Mon Feb 01, 2021 7:32 am 
Offline

Joined: Thu Jan 28, 2021 12:05 pm
Posts: 1
This is my contribution to everyone trying to burn sst chips with willem.

The information is very scarse over the internet i´ve searched for days, and finnaly ive burned a ship successfully, that can be read by my ecu (if you burn a chip for your honda and wont rev past 4k its not reading the chip).
This is how i made it work:

Usefull video: h**ps://www.youtube.com/watch?v=rjZFa3TgPYI - "Willem Burner How-To - SpiderRPM Honda Tuning"

Instructions:
1-Connect Willem with parallel cable/lpt cable both ends. (USB-LPT wont work)
-Power willem with USB Cable (Male-male)

2-Go to bios change Parallel/LPT port settings to EPP.

3-Download 0.97ja software version and io.dll fix here: h**p://benryves.com/products/remappediodll

"Install the Willem EPROM/FLASH Programmer software normally, then copy io.dll, io.ini and inpout32.dll to its installation directory (it should contain the current io.dll). Open io.ini and change the default address (0x378) to the base address of your parallel port." (Should be that easy, follow the instructions on the site)

4- Open 0.97ja program execute as administrator and compatible mode if you´re not on XP, otherwise wont have conection.
- In the program go to: "Help" - "Test Hardware". In the bottom bar it should read Hardware present, if not you did something wrong.
- In eddevice button select your sst chip: eddevice-> Eprom eletrical erase-> sst27sfxxx-> sst27sf512
- In the top it should read PCB3 in blue if it says willem click and change.
- Put the dip switch accordingly to the image.

(!! move jumpers j9 and j10 to the right to select version 0.97ja otherwise wont be able to burn !!)

5.To erase chpips. Place chip in willem, put the safety jumper in the 2 pins. (j1 (?) for willem 5.0, right of the chip socket first 2 pins vertically)
click erase, and check if the chip is empty (follow video intructions) (to save the previous map follow point 8.)
-Remove safety pin.

6.Burnning
-Place your chip
-Load the 32kb file you got from Crome or wtv.
-In the dial boxes (Bottom right of the program) put exactly or will not work:
-Offset hex: "008000" (This is the adress for the second part of the chip, where the ecu will read)
-Check type: "32 bit CRC" (ECU wont read 16-bit)
-Printer port: LPT1 (0x378) (it should be the port you are using)
7- Program Chip!


8- To read chips. In bottom menu, second page you can see the lines to be burned or read from the chip. Clear the buffer and read chip, save it. Then you will have a 64k file (Chips has 2 halfs 32k+32k=64k), open in notebook and delete the first empty half, reads "yyyy". you should get a 32.00kb file you can now open in Crome.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group